#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:17 UTC (full logs).

Meeting summary

  1. 0.14.1 (wumpus, 19:01:13)
  2. scripted-diffs (wumpus, 19:13:56)
    1. https://github.com/bitcoin/bitcoin/issues/10189 | devtools/net: add a verifier for scriptable changes. Use it to make CNode::id private. by theuni · Pull Request #10189 · bitcoin/bitcoin · GitHub (gribble, 19:14:46)
    2. https://github.com/bitcoin/bitcoin/issues/10193 | scripted-diff: Remove #include foreach.hpp> by jtimon · Pull Request #10193 · bitcoin bitcoin · GitHub (gribble, 19:17:58)
    3. https://github.com/bitcoin/bitcoin/commit/bac5c9cf643e9333479ac667426d0b70f8f3aa7f (cfields_, 19:20:23)
    4. ACTION: review #10193 (wumpus, 19:30:17)
    5. https://github.com/bitcoin/bitcoin/issues/10193 | scripted-diff: Remove #include foreach.hpp> by jtimon · Pull Request #10193 · bitcoin bitcoin · GitHub (gribble, 19:30:20)
    6. ACTION: review #10189 (wumpus, 19:31:11)
    7. https://github.com/bitcoin/bitcoin/issues/10189 | devtools/net: add a verifier for scriptable changes. Use it to make CNode::id private. by theuni · Pull Request #10189 · bitcoin/bitcoin · GitHub (gribble, 19:31:12)

  3. goals for 0.15 (wumpus, 19:31:56)
    1. Release schedule for 0.15.0 https://github.com/bitcoin/bitcoin/issues/9961 (wumpus, 19:34:58)
    2. https://github.com/bitcoin/bitcoin/issues/10179 | Give CValidationInterface Support for calling notifications on the CScheduler Thread by TheBlueMatt · Pull Request #10179 · bitcoin/bitcoin · GitHub (gribble, 19:37:23)
    3. ACTION: activate segwit (wumpus, 19:39:37)
    4. https://github.com/bitcoin/bitcoin/issues/10143 | [net] Allow disconnectnode RPC to be called with node id by jnewbery · Pull Request #10143 · bitcoin/bitcoin · GitHub (gribble, 19:43:50)
    5. https://github.com/bitcoin/bitcoin/issues/10102 | bitcoin-qt: spawn bitcoind and communicate over pipe (Experimental, WIP) by ryanofsky · Pull Request #10102 · bitcoin/bitcoin · GitHub (gribble, 19:51:12)

  4. multiprocess (wumpus, 19:51:37)
    1. https://github.com/bitcoin/bitcoin/issues/10102 | bitcoin-qt: spawn bitcoind and communicate over pipe (Experimental, WIP) by ryanofsky · Pull Request #10102 · bitcoin/bitcoin · GitHub (gribble, 19:52:04)

  5. high-priority PR review requests (wumpus, 19:56:20)
    1. https://github.com/bitcoin/bitcoin/issues/10179 | Give CValidationInterface Support for calling notifications on the CScheduler Thread by TheBlueMatt · Pull Request #10179 · bitcoin/bitcoin · GitHub (gribble, 19:56:34)
    2. https://github.com/bitcoin/bitcoin/issues/9792 | FastRandomContext improvements and switch to ChaCha20 by sipa · Pull Request #9792 · bitcoin/bitcoin · GitHub (gribble, 19:57:11)
    3. https://github.com/bitcoin/bitcoin/issues/9942 | Refactor CBlockPolicyEstimator by morcos · Pull Request #9942 · bitcoin/bitcoin · GitHub (gribble, 19:57:13)
    4. https://github.com/bitcoin/bitcoin/issues/10044 | Run functional tests in `make check` by jnewbery · Pull Request #10044 · bitcoin/bitcoin · GitHub (gribble, 19:58:28)


Meeting ended at 20:00:04 UTC (full logs).

Action items

  1. review #10193
  2. review #10189
  3. activate segwit


People present (lines said)

  1. wumpus (76)
  2. gmaxwell (55)
  3. BlueMatt (44)
  4. cfields_ (42)
  5. sipa (28)
  6. spudowiar (21)
  7. luke-jr (17)
  8. gribble (12)
  9. morcos (12)
  10. petertodd (11)
  11. jonasschnelli (10)
  12. sdaftuar (6)
  13. jnewbery (5)
  14. ryanofsky (4)
  15. instagibbs (3)
  16. luke-jr_ (3)
  17. BlueMatt_ (3)
  18. kanzure (3)
  19. jcorgan (2)
  20. lightningbot (2)
  21. phantomcircuit (1)
  22. CodeShark (1)
  23. MarcoFalke (1)
  24. bitcoin-git (1)
  25. achow101 (1)


Generated by MeetBot 0.1.4.