#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:06 UTC (full logs).

Meeting summary

  1. 0.16.1 (wumpus, 19:01:56)
    1. https://github.com/bitcoin/bitcoin/issues/13317 | [0.16.1] Remainig backports by MarcoFalke · Pull Request #13317 · bitcoin/bitcoin · GitHub (gribble, 19:02:32)
    2. https://github.com/bitcoin/bitcoin/pull/12172 is a small thing, but it is a bugfix, perhaps it makes sense to backport it? (jtimon, 19:04:51)
    3. https://github.com/bitcoin/bitcoin/issues/12172 | Bugfix: RPC: savemempool: Dont save until LoadMempool() is finished by jtimon · Pull Request #12172 · bitcoin/bitcoin · GitHub (gribble, 19:05:13)
    4. https://github.com/bitcoin/bitcoin/issues/12431 | Only call NotifyBlockTip when chainActive changes by jamesob · Pull Request #12431 · bitcoin/bitcoin · GitHub (gribble, 19:06:15)
    5. https://github.com/bitcoin/bitcoin/issues/12863 | mempool_persist.py failing in travis · Issue #12863 · bitcoin/bitcoin · GitHub (gribble, 19:08:23)
    6. https://github.com/bitcoin/bitcoin/issues/13298 | Net: Random delays *per network group* to obfuscate transaction time by naumenkogs · Pull Request #13298 · bitcoin/bitcoin · GitHub (gribble, 19:10:39)

  2. Random delays *per network group* to obfuscate transaction time (wumpus, 19:11:08)
    1. ACTION: look at PR 13298 (wumpus, 19:13:33)

  3. GUI prune setting (provoostenator) (wumpus, 19:15:36)
    1. https://github.com/bitcoin/bitcoin/issues/13043 | [qt] OptionsDialog: add prune setting by Sjors · Pull Request #13043 · bitcoin/bitcoin · GitHub (gribble, 19:15:41)
    2. https://github.com/bitcoin/bitcoin/issues/11082 | Add new bitcoin_rw.conf file that is used for settings modified by this software itself by luke-jr · Pull Request #11082 · bitcoin/bitcoin · GitHub (gribble, 19:18:46)
    3. https://github.com/bitcoin/bitcoin/issues/12833 | [qt] move QSettings to bitcoin.conf where possible by Sjors · Pull Request #12833 · bitcoin/bitcoin · GitHub (gribble, 19:21:01)
    4. https://github.com/bitcoin/bitcoin/issues/13043 | [qt] OptionsDialog: add prune setting by Sjors · Pull Request #13043 · bitcoin/bitcoin · GitHub (gribble, 19:25:49)

  4. scantxoutset RPC command (jonasschnelli) (wumpus, 19:31:09)
    1. https://github.com/bitcoin/bitcoin/pull/12196#pullrequestreview-121570579 (jonasschnelli, 19:31:24)
    2. https://github.com/bitcoin/bitcoin/issues/12196 | Add scantxoutset RPC method by jonasschnelli · Pull Request #12196 · bitcoin/bitcoin · GitHub (gribble, 19:31:59)
    3. https://github.com/bitcoin/bitcoin/issues/7759 | [WIP] rest: Stream entire utxo set by laanwj · Pull Request #7759 · bitcoin/bitcoin · GitHub (gribble, 19:48:00)
    4. https://github.com/bitcoin/bitcoin/issues/13243 | Make reusable base class for auxiliary indices by jimpo · Pull Request #13243 · bitcoin/bitcoin · GitHub (gribble, 19:50:51)


Meeting ended at 19:59:27 UTC (full logs).

Action items

  1. look at PR 13298


People present (lines said)

  1. wumpus (73)
  2. jonasschnelli (57)
  3. sipa (36)
  4. provoostenator (30)
  5. gribble (12)
  6. jcorgan (12)
  7. jimpo (11)
  8. achow101 (9)
  9. MarcoFalke (8)
  10. instagibbs (8)
  11. cfields (6)
  12. jamesob (3)
  13. jtimon (3)
  14. echeveria (3)
  15. lightningbot (2)
  16. jnewbery (2)
  17. promag (1)
  18. kanzure (1)
  19. murch1 (1)


Generated by MeetBot 0.1.4.