#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:32 UTC (full logs).

Meeting summary

  1. high priority for review (wumpus, 19:02:27)
    1. https://github.com/bitcoin/bitcoin/issues/13425 | Moving final scriptSig construction from CombineSignatures to ProduceSignature (PSBT signer logic) by achow101 · Pull Request #13425 · bitcoin/bitcoin · GitHub (gribble, 19:02:42)
    2. https://github.com/bitcoin/bitcoin/issues/13111 | Add unloadwallet RPC by promag · Pull Request #13111 · bitcoin/bitcoin · GitHub (gribble, 19:02:45)
    3. https://github.com/bitcoin/bitcoin/issues/13062 | Make script interpreter independent from storage type CScript by sipa · Pull Request #13062 · bitcoin/bitcoin · GitHub (gribble, 19:02:47)
    4. https://github.com/bitcoin/bitcoin/issues/12196 | Add scantxoutset RPC method by jonasschnelli · Pull Request #12196 · bitcoin/bitcoin · GitHub (gribble, 19:02:51)
    5. https://github.com/bitcoin/bitcoin/issues/12136 | Implement BIP 174 Partially Signed Bitcoin Transactions serialization and RPCs by achow101 · Pull Request #12136 · bitcoin/bitcoin · GitHub (gribble, 19:02:58)
    6. https://github.com/bitcoin/bitcoin/issues/13425 | Moving final scriptSig construction from CombineSignatures to ProduceSignature (PSBT signer logic) by achow101 · Pull Request #13425 · bitcoin/bitcoin · GitHub (gribble, 19:04:12)
    7. https://github.com/bitcoin/bitcoin/issues/13160 | wallet: Unlock spent outputs by promag · Pull Request #13160 · bitcoin/bitcoin · GitHub (gribble, 19:07:27)
    8. ACTION: look at #13160 (wumpus, 19:10:33)
    9. https://github.com/bitcoin/bitcoin/issues/13160 | wallet: Unlock spent outputs by promag · Pull Request #13160 · bitcoin/bitcoin · GitHub (gribble, 19:10:35)

  2. srd fallback coin selection (achow101) (wumpus, 19:11:40)
    1. https://github.com/bitcoin/bitcoin/issues/13307 | Replace coin selection fallback strategy with Single Random Draw by achow101 · Pull Request #13307 · bitcoin/bitcoin · GitHub (gribble, 19:12:22)
    2. https://github.com/bitcoin/bitcoin/issues/13439 | rpc: Avoid "duplicate" return value for invalid submitblock by TheBlueMatt · Pull Request #13439 · bitcoin/bitcoin · GitHub (gribble, 19:33:25)
    3. https://github.com/bitcoin/bitcoin/issues/13471 | For AVX2 code, also check for AVX, XSAVE, and OS support by sipa · Pull Request #13471 · bitcoin/bitcoin · GitHub (gribble, 19:39:40)
    4. https://github.com/bitcoin/bitcoin/issues/13386 | SHA256 implementations based on Intel SHA Extensions by sipa · Pull Request #13386 · bitcoin/bitcoin · GitHub (gribble, 19:39:42)
    5. https://github.com/bitcoin/bitcoin/issues/13442 | Convert the 1-way SSE4 SHA256 code from asm to intrinsics by sipa · Pull Request #13442 · bitcoin/bitcoin · GitHub (gribble, 19:39:43)
    6. https://github.com/bitcoin/bitcoin/issues/13438 | Improve coverage of SHA256 SelfTest code by sipa · Pull Request #13438 · bitcoin/bitcoin · GitHub (gribble, 19:39:44)
    7. https://github.com/bitcoin/bitcoin/issues/13203 | Add POWER8 ASM for 4-way SHA256 by TheBlueMatt · Pull Request #13203 · bitcoin/bitcoin · GitHub (gribble, 19:47:50)
    8. https://github.com/bitcoin-core/bitcoin-detached-sigs/pull/8 (jonasschnelli, 19:54:45)


Meeting ended at 20:00:09 UTC (full logs).

Action items

  1. look at #13160


People present (lines said)

  1. wumpus (56)
  2. sipa (39)
  3. instagibbs (21)
  4. achow101 (21)
  5. cfields (16)
  6. gribble (15)
  7. promag (8)
  8. meshcollider (5)
  9. luke-jr (5)
  10. jonasschnelli (5)
  11. MarcoFalke (2)
  12. jnewbery (2)
  13. lightningbot (2)
  14. kanzure (1)
  15. bitcoin-git (1)
  16. ryanofsky (1)
  17. GitHub133 (1)


Generated by MeetBot 0.1.4.