#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:52 UTC (full logs).

Meeting summary

  1. 0.17.0 release (wumpus, 19:05:32)
    1. https://github.com/bitcoin/bitcoin/issues/14339 | Qt 0.17.0rc4 (and master) not running on Ubuntu 14.04.5 LTS · Issue #14339 · bitcoin/bitcoin · GitHub (gribble, 19:06:24)
    2. https://github.com/bitcoin/bitcoin/issues/14327 | macOS Mojave QT 5.11 compilation fails · Issue #14327 · bitcoin/bitcoin · GitHub (gribble, 19:06:44)
    3. https://github.com/bitcoin/bitcoin/issues/14289 | Unbounded growth of scheduler queue · Issue #14289 · bitcoin/bitcoin · GitHub (gribble, 19:06:50)
    4. https://github.com/bitcoin/bitcoin/issues/14289 | Unbounded growth of scheduler queue · Issue #14289 · bitcoin/bitcoin · GitHub (gribble, 19:09:43)
    5. https://github.com/bitcoin/bitcoin/issues/14104 | 0.17.2rc issue (standardness change for bare multisig) · Issue #14104 · bitcoin/bitcoin · GitHub (gribble, 19:09:44)
    6. https://github.com/bitcoin/bitcoin/issues/14289 | Unbounded growth of scheduler queue · Issue #14289 · bitcoin/bitcoin · GitHub (gribble, 19:09:51)
    7. https://github.com/bitcoin/bitcoin/issues/14104 | 0.17.2rc issue (standardness change for bare multisig) · Issue #14104 · bitcoin/bitcoin · GitHub (gribble, 19:10:06)
    8. https://github.com/bitcoin/bitcoin/issues/14328 | [0.17] Backports by MarcoFalke · Pull Request #14328 · bitcoin/bitcoin · GitHub (gribble, 19:26:20)
    9. https://github.com/bitcoin/bitcoin/issues/14336 | net: implement poll by pstratem · Pull Request #14336 · bitcoin/bitcoin · GitHub (gribble, 19:33:58)

  2. Travis error on poll() PR (wumpus, 19:34:25)
    1. ACTION: try to run tests on #14336 on different environments to see if it reproduces travis error (wumpus, 19:35:43)
    2. https://github.com/bitcoin/bitcoin/issues/14336 | net: implement poll by pstratem · Pull Request #14336 · bitcoin/bitcoin · GitHub (gribble, 19:35:45)

  3. multiwallet (promag) (wumpus, 19:36:02)
    1. https://github.com/bitcoin/bitcoin/issues/14046 | net: Refactor message parsing (CNetMessage), adds flexibility by jonasschnelli · Pull Request #14046 · bitcoin/bitcoin · GitHub (gribble, 19:37:55)
    2. https://github.com/bitcoin/bitcoin/issues/13100 | gui: Add dynamic wallets support by promag · Pull Request #13100 · bitcoin/bitcoin · GitHub (gribble, 19:38:03)

  4. factor out berekey-db (wumpus, 19:43:06)
    1. https://github.com/bitcoin/bitcoin/issues/5686 | [Wallet] replace BDB with internal append only (logdb) backend by jonasschnelli · Pull Request #5686 · bitcoin/bitcoin · GitHub (gribble, 19:47:57)


Meeting ended at 19:58:55 UTC (full logs).

Action items

  1. try to run tests on #14336 on different environments to see if it reproduces travis error


People present (lines said)

  1. wumpus (72)
  2. jonasschnelli (45)
  3. gmaxwell (38)
  4. sipa (32)
  5. provoostenator (19)
  6. luke-jr (15)
  7. promag (14)
  8. phantomcircuit (14)
  9. gribble (13)
  10. cfields (10)
  11. jamesob (9)
  12. instagibbs (6)
  13. achow101 (6)
  14. lightningbot (2)
  15. meshcollider (1)


Generated by MeetBot 0.1.4.