#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:49 UTC (full logs).

Meeting summary

  1. high priority for review (wumpus, 19:01:27)
    1. https://github.com/bitcoin/bitcoin/issues/10882 | Keypool topup by jnewbery · Pull Request #10882 · bitcoin/bitcoin · GitHub (gribble, 19:02:11)
    2. https://github.com/bitcoin/bitcoin/projects/8 has pretty much been cleaned out (only #10652 left), anything new? (wumpus, 19:02:15)
    3. https://github.com/bitcoin/bitcoin/issues/10652 | Small step towards demangling cs_main from CNodeState by TheBlueMatt · Pull Request #10652 · bitcoin/bitcoin · GitHub (gribble, 19:02:17)
    4. https://github.com/bitcoin/bitcoin/pulls?q=is%3Aopen+is%3Apr+milestone%3A0.15.0 (wumpus, 19:02:36)
    5. https://github.com/bitcoin/bitcoin/issues/10758 | Fix some chainstate-init-order bugs. by TheBlueMatt · Pull Request #10758 · bitcoin/bitcoin · GitHub (gribble, 19:03:12)
    6. https://github.com/bitcoin/bitcoin/issues/10821 | Add SSE4 optimized SHA256 by sipa · Pull Request #10821 · bitcoin/bitcoin · GitHub (gribble, 19:03:36)
    7. https://github.com/bitcoin/bitcoin/issues/10758 | Fix some chainstate-init-order bugs. by TheBlueMatt · Pull Request #10758 · bitcoin/bitcoin · GitHub (gribble, 19:05:48)
    8. https://github.com/bitcoin/bitcoin/issues/10882 | Keypool topup by jnewbery · Pull Request #10882 · bitcoin/bitcoin · GitHub (gribble, 19:05:49)
    9. https://github.com/bitcoin/bitcoin/issues/10652 | Small step towards demangling cs_main from CNodeState by TheBlueMatt · Pull Request #10652 · bitcoin/bitcoin · GitHub (gribble, 19:06:46)
    10. https://github.com/bitcoin/bitcoin/issues/10526 | Force on-the-fly compaction during pertxout upgrade by sipa · Pull Request #10526 · bitcoin/bitcoin · GitHub (gribble, 19:08:40)

  2. Force on-the-fly compaction during pertxout upgrade (wumpus, 19:09:20)
    1. ACTION: test #10526 (wumpus, 19:13:19)
    2. https://github.com/bitcoin/bitcoin/issues/10526 | Force on-the-fly compaction during pertxout upgrade by sipa · Pull Request #10526 · bitcoin/bitcoin · GitHub (gribble, 19:13:20)

  3. 10882 halting condition (wumpus, 19:18:29)
    1. https://github.com/bitcoin/bitcoin/issues/10740 | [WIP] [wallet] dynamic loading/unloading of wallets by jnewbery · Pull Request #10740 · bitcoin/bitcoin · GitHub (gribble, 19:23:22)
    2. https://github.com/bitcoin/bitcoin/issues/8745 | [PoC] Add wallet inspection and modification tool "bitcoin-wallet-tool" by jonasschnelli · Pull Request #8745 · bitcoin/bitcoin · GitHub (gribble, 19:23:23)
    3. ACTION: review #10882 (wumpus, 19:34:44)
    4. https://github.com/bitcoin/bitcoin/issues/10882 | Keypool topup by jnewbery · Pull Request #10882 · bitcoin/bitcoin · GitHub (gribble, 19:34:46)


Meeting ended at 19:44:01 UTC (full logs).

Action items

  1. test #10526
  2. review #10882


People present (lines said)

  1. wumpus (48)
  2. gmaxwell (25)
  3. sipa (23)
  4. instagibbs (18)
  5. gribble (12)
  6. jnewbery (9)
  7. BlueMatt (8)
  8. cfields (4)
  9. jtimon (2)
  10. btcdrak (2)
  11. achow101 (2)
  12. lightningbot (2)
  13. kanzure (1)
  14. jonasschnelli (1)


Generated by MeetBot 0.1.4.