#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:01:29 UTC (full logs).

Meeting summary

    1. ACTION: find the bot (wumpus, 19:02:38)

  1. High priority for review (wumpus, 19:03:42)
    1. https://github.com/bitcoin/bitcoin/issues/10387 | Implement BIP159, define and signal NODE_NETWORK_LIMITED (pruned peers) by jonasschnelli · Pull Request #10387 · bitcoin/bitcoin · GitHub (gribble, 19:05:35)

  2. put up 0.16 release schedule (wumpus, 19:06:01)
    1. https://github.com/bitcoin/bitcoin/issues/11089 | Enable various p2sh-p2wpkh functionality by luke-jr · Pull Request #11089 · bitcoin/bitcoin · GitHub (gribble, 19:07:00)
    2. https://github.com/bitcoin/bitcoin/issues/10637 | Coin Selection with Murchs algorithm by achow101 · Pull Request #10637 · bitcoin/bitcoin · GitHub (gribble, 19:07:05)
    3. https://github.com/bitcoin/bitcoin/issues/11403 | SegWit wallet support by sipa · Pull Request #11403 · bitcoin/bitcoin · GitHub (gribble, 19:07:38)
    4. https://github.com/bitcoin/bitcoin/issues/10615 | RPC: Allow rpcauth configs to specify a 4th parameter naming a specific wallet (multiwallet RPC support) by luke-jr · Pull Request #10615 · bitcoin/bitcoin · GitHub (gribble, 19:09:19)
    5. https://github.com/bitcoin/bitcoin/issues/7965 | Remaining instances of ENABLE_WALLET in `libbitcoin_server.a` · Issue #7965 · bitcoin/bitcoin · GitHub (gribble, 19:12:54)
    6. ACTION: refactor #10615 for a "populate JSONRequest" callback, and separate out rpcauth stuff (luke-jr, 19:14:28)
    7. https://github.com/bitcoin/bitcoin/issues/10615 | RPC: Allow rpcauth configs to specify a 4th parameter naming a specific wallet (multiwallet RPC support) by luke-jr · Pull Request #10615 · bitcoin/bitcoin · GitHub (gribble, 19:14:29)
    8. https://github.com/bitcoin/bitcoin/issues/11383 | Basic Multiwallet GUI support by luke-jr · Pull Request #11383 · bitcoin/bitcoin · GitHub (gribble, 19:18:19)

  3. RPC long poll (wumpus, 19:19:48)
    1. https://github.com/bitcoin/bitcoin/issues/10554 | ZMQ: add publishers for wallet transactions. by somdoron · Pull Request #10554 · bitcoin/bitcoin · GitHub (gribble, 19:29:39)

  4. segwit wallet support (wumpus, 19:35:06)
    1. https://github.com/bitcoin/bitcoin/issues/11403 | SegWit wallet support by sipa · Pull Request #11403 · bitcoin/bitcoin · GitHub (gribble, 19:35:52)

  5. suggested topic: next Bitcoin Core meetup (jnewbery) (wumpus, 19:58:59)
    1. https://www.irccloud.com/pastebin/XrHj6tr8 (meshcollider, 20:03:20)


Meeting ended at 20:03:23 UTC (full logs).

Action items

  1. find the bot
  2. refactor #10615 for a "populate JSONRequest" callback, and separate out rpcauth stuff


People present (lines said)

  1. wumpus (79)
  2. jonasschnelli (62)
  3. BlueMatt (60)
  4. sipa (56)
  5. luke-jr (53)
  6. gmaxwell (48)
  7. morcos (15)
  8. gribble (10)
  9. cfields (10)
  10. achow101 (8)
  11. jnewbery (7)
  12. meshcollider (5)
  13. instagibbs (4)
  14. lightningbot (2)
  15. promag (2)
  16. sdaftuar (2)
  17. Chris_Stewart_5 (1)
  18. petertodd (1)
  19. kanzure (1)


Generated by MeetBot 0.1.4.