#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:51 UTC (full logs).

Meeting summary

  1. high priority for review (wumpus, 19:01:46)
    1. https://github.com/bitcoin/bitcoin/projects/8 (wumpus, 19:01:55)
    2. https://github.com/bitcoin/bitcoin/issues/11403 | SegWit wallet support by sipa · Pull Request #11403 · bitcoin/bitcoin · GitHub (gribble, 19:02:57)
    3. https://github.com/bitcoin/bitcoin/issues/11383 | Basic Multiwallet GUI support by luke-jr · Pull Request #11383 · bitcoin/bitcoin · GitHub (gribble, 19:03:49)
    4. https://github.com/bitcoin/bitcoin/issues/10740 | [wallet] dynamic loading/unloading of wallets by jnewbery · Pull Request #10740 · bitcoin/bitcoin · GitHub (gribble, 19:04:13)
    5. https://github.com/bitcoin/bitcoin/issues/11839 | dont attempt mempool entry for wallet transactions on startup if alr… by instagibbs · Pull Request #11839 · bitcoin/bitcoin · GitHub (gribble, 19:04:49)
    6. https://github.com/bitcoin/bitcoin/issues/11824 | Block ActivateBestChain to empty validationinterface queue by TheBlueMatt · Pull Request #11824 · bitcoin/bitcoin · GitHub (gribble, 19:07:15)
    7. https://github.com/bitcoin/bitcoin/issues/11824 | Block ActivateBestChain to empty validationinterface queue by TheBlueMatt · Pull Request #11824 · bitcoin/bitcoin · GitHub (gribble, 19:08:12)
    8. ACTION: merge #11824 (wumpus, 19:08:37)
    9. https://github.com/bitcoin/bitcoin/issues/11824 | Block ActivateBestChain to empty validationinterface queue by TheBlueMatt · Pull Request #11824 · bitcoin/bitcoin · GitHub (gribble, 19:08:39)
    10. https://github.com/bitcoin/bitcoin/issues/11800 | Bitcoin is returning higher fees for 36 block window than 2 block window (on testnet) · Issue #11800 · bitcoin/bitcoin · GitHub (gribble, 19:12:46)

  2. Bitcoin is returning higher fees for 36 block window than 2 block window (on testnet) (wumpus, 19:13:46)
    1. https://github.com/bitcoin/bitcoin/issues/11363 | net: Split socket create/connect by theuni · Pull Request #11363 · bitcoin/bitcoin · GitHub (gribble, 19:13:47)
    2. ACTION: review #11363 (wumpus, 19:14:11)
    3. https://github.com/bitcoin/bitcoin/issues/11363 | net: Split socket create/connect by theuni · Pull Request #11363 · bitcoin/bitcoin · GitHub (gribble, 19:14:14)
    4. https://github.com/bitcoin/bitcoin/issues/11800 | Bitcoin is returning higher fees for 36 block window than 2 block window (on testnet) · Issue #11800 · bitcoin/bitcoin · GitHub (gribble, 19:15:07)
    5. https://github.com/bitcoin/bitcoin/issues/11826 | RFC: Activity feature · Issue #11826 · bitcoin/bitcoin · GitHub (gribble, 19:19:28)
    6. https://github.com/bitcoin/bitcoin/issues/10996 | Add per-network config file network.conf by ajtowns · Pull Request #10996 · bitcoin/bitcoin · GitHub (gribble, 19:23:01)
    7. https://github.com/bitcoin/bitcoin/issues/10267 | New -includeconf argument for including external configuration files by kallewoof · Pull Request #10267 · bitcoin/bitcoin · GitHub (gribble, 19:23:03)

  3. config file handling (wumpus, 19:23:08)
    1. https://github.com/bitcoin/bitcoin/issues/10267 | New -includeconf argument for including external configuration files by kallewoof · Pull Request #10267 · bitcoin/bitcoin · GitHub (gribble, 19:28:09)
    2. https://github.com/bitcoin/bitcoin/issues/11826 | RFC: Activity feature · Issue #11826 · bitcoin/bitcoin · GitHub (gribble, 19:32:13)

  4. activity feature (wumpus, 19:33:01)
    1. https://github.com/bitcoin/bitcoin/issues/5896 | [Qt][PoC] introduce "core-pulse" by jonasschnelli · Pull Request #5896 · bitcoin/bitcoin · GitHub (gribble, 19:40:14)

  5. libgmp dependency (wumpus, 19:49:46)
    1. https://github.com/bitcoin/bitcoin/issues/10434 | [WIP] 3072-bit MuHash based hash_serialized by sipa · Pull Request #10434 · bitcoin/bitcoin · GitHub (gribble, 19:53:23)


Meeting ended at 20:00:26 UTC (full logs).

Action items

  1. merge #11824
  2. review #11363


People present (lines said)

  1. wumpus (84)
  2. BlueMatt (56)
  3. jonasschnelli (36)
  4. sipa (31)
  5. meshcollider (19)
  6. promag (19)
  7. gribble (18)
  8. cfields (11)
  9. morcos (11)
  10. instagibbs (9)
  11. Randolf (7)
  12. achow101 (6)
  13. aj (5)
  14. midnightmagic (3)
  15. gmaxwell (3)
  16. Provoostenator (3)
  17. jnewbery (2)
  18. phantomcircuit (2)
  19. lightningbot (2)
  20. ryanofsky (1)
  21. adiabat (1)
  22. kanzure (1)
  23. michagogo (1)


Generated by MeetBot 0.1.4.