#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:54 UTC (full logs).

Meeting summary

  1. High priority for review (wumpus, 19:02:29)
    1. https://github.com/bitcoin/bitcoin/issues/11082 | Add new bitcoin_rw.conf file that is used for settings modified by this software itself by luke-jr · Pull Request #11082 · bitcoin/bitcoin · GitHub (gribble, 19:03:13)
    2. https://github.com/bitcoin/bitcoin/issues/14491 | Allow descriptor imports with importmulti by MeshCollider · Pull Request #14491 · bitcoin/bitcoin · GitHub (gribble, 19:03:16)
    3. https://github.com/bitcoin/bitcoin/issues/14711 | Remove uses of chainActive and mapBlockIndex in wallet code by ryanofsky · Pull Request #14711 · bitcoin/bitcoin · GitHub (gribble, 19:03:21)
    4. https://github.com/bitcoin/bitcoin/issues/14897 | randomize GETDATA(tx) request order and introduce bias toward outbound by naumenkogs · Pull Request #14897 · bitcoin/bitcoin · GitHub (gribble, 19:03:23)
    5. https://github.com/bitcoin/bitcoin/issues/15153 | gui: Add Open Wallet menu by promag · Pull Request #15153 · bitcoin/bitcoin · GitHub (gribble, 19:03:25)
    6. https://github.com/bitcoin/bitcoin/issues/15226 | Allow creating blank (empty) wallets (alternative) by achow101 · Pull Request #15226 · bitcoin/bitcoin · GitHub (gribble, 19:03:27)
    7. https://github.com/bitcoin/bitcoin/issues/15225 | GUI: Change the receive button to respond to keypool state changing by achow101 · Pull Request #15225 · bitcoin/bitcoin · GitHub (gribble, 19:04:23)
    8. https://github.com/bitcoin/bitcoin/issues/15118 | Refactor block file logic by jimpo · Pull Request #15118 · bitcoin/bitcoin · GitHub (gribble, 19:04:33)
    9. https://github.com/bitcoin/bitcoin/issues/15118 | Refactor block file logic by jimpo · Pull Request #15118 · bitcoin/bitcoin · GitHub (gribble, 19:05:15)
    10. https://github.com/bitcoin/bitcoin/issues/14121 | Index for BIP 157 block filters by jimpo · Pull Request #14121 · bitcoin/bitcoin · GitHub (gribble, 19:05:19)
    11. https://github.com/bitcoin/bitcoin/issues/13932 | Additional utility RPCs for PSBT by achow101 · Pull Request #13932 · bitcoin/bitcoin · GitHub (gribble, 19:05:42)
    12. https://github.com/bitcoin/bitcoin/issues/15225 | GUI: Change the receive button to respond to keypool state changing by achow101 · Pull Request #15225 · bitcoin/bitcoin · GitHub (gribble, 19:08:00)
    13. https://github.com/bitcoin/bitcoin/issues/15118 | Refactor block file logic by jimpo · Pull Request #15118 · bitcoin/bitcoin · GitHub (gribble, 19:08:02)
    14. https://github.com/bitcoin/bitcoin/issues/15141 | Rewrite DoS interface between validation and net_processing by sdaftuar · Pull Request #15141 · bitcoin/bitcoin · GitHub (gribble, 19:10:04)

  2. Globals and initialization order (sipa) (wumpus, 19:11:07)
    1. https://github.com/bitcoin/bitcoin/issues/14955 | Switch all RNG code to the built-in PRNG by sipa · Pull Request #14955 · bitcoin/bitcoin · GitHub (gribble, 19:16:36)

  3. Chaincode summer residency (jnewbery) (wumpus, 19:32:39)
    1. https://github.com/bitcoin/bitcoin/issues/14929 | net: Allow connections from misbehavior banned peers by gmaxwell · Pull Request #14929 · bitcoin/bitcoin · GitHub (gribble, 19:42:36)
    2. ACTION: review #14929 (wumpus, 19:43:18)
    3. https://github.com/bitcoin/bitcoin/issues/14929 | net: Allow connections from misbehavior banned peers by gmaxwell · Pull Request #14929 · bitcoin/bitcoin · GitHub (gribble, 19:43:21)


Meeting ended at 19:47:19 UTC (full logs).

Action items

  1. review #14929


People present (lines said)

  1. wumpus (49)
  2. sipa (33)
  3. jnewbery (19)
  4. gribble (17)
  5. gmaxwell (12)
  6. jamesob (5)
  7. instagibbs (4)
  8. promag (4)
  9. sdaftuar (4)
  10. luke-jr (3)
  11. gwillen (3)
  12. provoostenator (3)
  13. achow101 (3)
  14. meshcollider (2)
  15. lightningbot (2)
  16. phantomcircuit (1)
  17. jimpo (1)
  18. moneyball (1)
  19. marcinja (1)
  20. kanzure (1)
  21. promag_ (1)
  22. jonasschnelli (1)


Generated by MeetBot 0.1.4.