#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:00:04 UTC (full logs).

Meeting summary

  1. 0.18.0rc4 (wumpus, 19:01:07)
    1. https://github.com/bitcoin/bitcoin/issues/15839 | [0.18] Revert GetData randomization change (#14897) by sdaftuar · Pull Request #15839 · bitcoin/bitcoin · GitHub (gribble, 19:01:23)
    2. ACTION: merge 15839 and tag rc4 (MarcoFalke, 19:02:50)

  2. High priority for review (wumpus, 19:03:27)
    1. https://github.com/bitcoin/bitcoin/pulls?q=is%3Aopen+is%3Apr+project%3Abitcoin%2Fbitcoin%2F8 6 PRs on there right now (wumpus, 19:03:39)
    2. https://github.com/bitcoin/bitcoin/issues/15427 | Add support for descriptors to utxoupdatepsbt by sipa · Pull Request #15427 · bitcoin/bitcoin · GitHub (gribble, 19:05:01)
    3. https://github.com/bitcoin/bitcoin/issues/15758 | qa: Add further tests to wallet_balance by MarcoFalke · Pull Request #15758 · bitcoin/bitcoin · GitHub (gribble, 19:05:04)
    4. https://github.com/bitcoin/bitcoin/issues/15024 | Allow specific private keys to be derived from descriptor by meshcollider · Pull Request #15024 · bitcoin/bitcoin · GitHub (gribble, 19:05:43)
    5. https://github.com/bitcoin/bitcoin/issues/15741 | Batch write imported stuff in importmulti by achow101 · Pull Request #15741 · bitcoin/bitcoin · GitHub (gribble, 19:09:46)
    6. https://gist.github.com/moneyball/071d608fdae217c2a6d7c35955881d8a (moneyball, 19:11:16)

  3. Should send-to-non-v0-witness be standard (sipa) (wumpus, 19:12:09)
  4. Bitcoin Core design documentation (jnewbery) (wumpus, 19:36:22)
    1. https://github.com/bitcoin-core/bitcoin-devwiki/wiki (wumpus, 19:43:36)

  5. opportunity to provide feedback with GitHub CEO (moneyball) (wumpus, 19:45:49)


Meeting ended at 19:57:44 UTC (full logs).

Action items

  1. merge 15839 and tag rc4


People present (lines said)

  1. wumpus (72)
  2. gmaxwell (62)
  3. luke-jr (53)
  4. sipa (45)
  5. MarcoFalke (36)
  6. jnewbery (35)
  7. jonasschnelli (32)
  8. instagibbs (16)
  9. moneyball (16)
  10. sdaftuar (12)
  11. cfields (11)
  12. meshcollider (10)
  13. achow101 (10)
  14. gwillen (9)
  15. gribble (5)
  16. ryanofsky (3)
  17. jonasschnelli_ (2)
  18. lightningbot (2)
  19. jamesob (1)
  20. kanzure (1)


Generated by MeetBot 0.1.4.