#bitcoin-core-dev Meeting

Meeting started by wumpus at 19:01:14 UTC (full logs).

Meeting summary

    1. https://github.com/bitcoin/bitcoin/issues/16704 | Dont warn about activated buried BIP 9 deployments by achow101 · Pull Request #16704 · bitcoin/bitcoin · GitHub (gribble, 19:02:34)
    2. https://github.com/bitcoin/bitcoin/issues/16713 | Ignore old versionbit activations to avoid unknown softforks warning by jnewbery · Pull Request #16713 · bitcoin/bitcoin · GitHub (gribble, 19:02:36)

  1. High priority for review (wumpus, 19:03:47)
    1. https://github.com/bitcoin/bitcoin/issues/16702 | p2p: supplying and using asmap to improve IP bucketing in addrman by naumenkogs · Pull Request #16702 · bitcoin/bitcoin · GitHub (gribble, 19:05:35)
    2. https://github.com/bitcoin/bitcoin/issues/15759 | p2p: Add 2 outbound block-relay-only connections by sdaftuar · Pull Request #15759 · bitcoin/bitcoin · GitHub (gribble, 19:05:51)
    3. https://github.com/bitcoin/bitcoin/issues/16766 | wallet: Make IsTrusted scan parents recursively by JeremyRubin · Pull Request #16766 · bitcoin/bitcoin · GitHub (gribble, 19:08:37)

  2. remove worrying "unknown new rules activated (versionbit 1)" warning (jnewbery) (wumpus, 19:13:26)
    1. https://github.com/bitcoin/bitcoin/issues/16704 | Dont warn about activated buried BIP 9 deployments by achow101 · Pull Request #16704 · bitcoin/bitcoin · GitHub (gribble, 19:13:55)
    2. https://github.com/bitcoin/bitcoin/issues/16713 | Ignore old versionbit activations to avoid unknown softforks warning by jnewbery · Pull Request #16713 · bitcoin/bitcoin · GitHub (gribble, 19:13:56)
    3. ACTION: please review #16713 so that it can be merged asap (wumpus, 19:24:04)
    4. https://github.com/bitcoin/bitcoin/issues/16713 | Ignore old versionbit activations to avoid unknown softforks warning by jnewbery · Pull Request #16713 · bitcoin/bitcoin · GitHub (gribble, 19:24:06)

  3. Rolling UTXO set hash (fjahr) (wumpus, 19:25:07)
    1. https://gist.github.com/fjahr/fa4892874b090d3a4f4fccc5bafa0210 (fjahr, 19:26:23)

  4. avoid loading every wallet transaction into memory (achow101) (wumpus, 19:40:13)
    1. https://github.com/bitcoin/bitcoin/issues/5686 | [Wallet] replace BDB with internal append only (logdb) backend by jonasschnelli · Pull Request #5686 · bitcoin/bitcoin · GitHub (gribble, 19:42:51)


Meeting ended at 19:53:03 UTC (full logs).

Action items

  1. please review #16713 so that it can be merged asap


People present (lines said)

  1. wumpus (56)
  2. sipa (46)
  3. achow101 (18)
  4. jeremyrubin (13)
  5. fjahr (12)
  6. gribble (9)
  7. jonasschnelli (9)
  8. aj (8)
  9. instagibbs (7)
  10. MarcoFalke (6)
  11. BlueMatt (3)
  12. gleb (2)
  13. lightningbot (2)
  14. meshcollider (1)
  15. jarthur (1)
  16. moneyball (1)
  17. jonatack (1)


Generated by MeetBot 0.1.4.