#lightning-dev Meeting

Meeting started by cdecker at 18:59:45 UTC (full logs).

Meeting summary

    1. Meeting agenda can be found here: http://bit.ly/ln-agenda-201902 (cdecker, 19:00:17)

  1. PR #491: BOLT #2: order htlc_signatures by BIP69 + increasing CLTV. (cdecker, 19:04:56)
    1. ACTION: BlueMatt to inline BIP69 into the BOLT to remove ambiguities (cdecker, 19:08:40)
    2. ACTION: cdecker to merge #491 (cdecker, 19:12:24)
    3. ACTION: The test vectors in #539 need to be verified independently. Decision is to be deferred until the next meeting (cdecker, 19:13:27)

  2. PR #500: BOLT 7: Add note for 'htlc_minimum_msat' being static (cdecker, 19:13:52)
    1. ACTION: roasbeef to amend PR #500 to remove the static definition or open a new PR to do that (cdecker, 19:20:38)

  3. PR #519: BOLT 7: add extended channel queries (cdecker, 19:21:16)
    1. ACTION: sstone to rework #519 with the feedback on the PR (cdecker, 19:36:55)

  4. PR #538: BOLT 4: Report outgoing HTLC values when appropriate (cdecker, 19:37:11)
    1. ACTION: sstone to merge #538 (cdecker, 19:57:00)

  5. PR #544: BOLT 4: remove incorrect_payment_amount altogether. (cdecker, 19:57:10)
    1. ACTION: cdecker to merge #544 (cdecker, 19:58:50)

  6. PR #545: BOLT 4: include `channel_update`'s message type (cdecker, 20:00:34)
    1. ACTION: sstone to rephrase the PR to include what to do when type is unknown, everybody to discuss lively on the PR (cdecker, 20:10:20)

  7. PR #546: Clarify behavior of id field in update_add_htlc (cdecker, 20:10:31)
    1. ACTION: cdecker to merge PR #546 (cdecker, 20:12:45)

  8. PR #547: Keep HMAC case consistent (cdecker, 20:12:54)
    1. https://tools.ietf.org/html/rfc2104 (roasbeef, 20:14:20)
    2. ACTION: BlueMatt to comment about the shed color not being uppercase (cdecker, 20:14:56)

  9. PR #548: Align offered and received HTLC scripts similarly (cdecker, 20:15:07)
    1. ACTION: cdecker to merge #548 (cdecker, 20:16:12)

  10. PR #550: dpl: concretely define `my_current_per_commitment_point` (cdecker, 20:16:19)
    1. ACTION: roasbeef to help with the wording of the PR to remove any remaining uncertainty (cdecker, 20:21:27)

  11. PR #552: Demand revoke_and_ack before more updates (cdecker, 20:21:35)
    1. ACTION: Defer #552 to the tracker (cdecker, 20:24:10)

  12. TLV format and multi-hop onion (cdecker, 20:28:47)
    1. ACTION: cdecker to review lightningnetwork/lightning-onion#31 (cdecker, 20:29:03)


Meeting ended at 20:31:22 UTC (full logs).

Action items

  1. BlueMatt to inline BIP69 into the BOLT to remove ambiguities
  2. cdecker to merge #491
  3. The test vectors in #539 need to be verified independently. Decision is to be deferred until the next meeting
  4. roasbeef to amend PR #500 to remove the static definition or open a new PR to do that
  5. sstone to rework #519 with the feedback on the PR
  6. sstone to merge #538
  7. cdecker to merge #544
  8. sstone to rephrase the PR to include what to do when type is unknown, everybody to discuss lively on the PR
  9. cdecker to merge PR #546
  10. BlueMatt to comment about the shed color not being uppercase
  11. cdecker to merge #548
  12. roasbeef to help with the wording of the PR to remove any remaining uncertainty
  13. Defer #552 to the tracker
  14. cdecker to review lightningnetwork/lightning-onion#31


Action items, by person

  1. BlueMatt
    1. BlueMatt to inline BIP69 into the BOLT to remove ambiguities
    2. BlueMatt to comment about the shed color not being uppercase
  2. cdecker
    1. cdecker to merge #491
    2. cdecker to merge #544
    3. cdecker to merge PR #546
    4. cdecker to merge #548
    5. cdecker to review lightningnetwork/lightning-onion#31
  3. roasbeef
    1. roasbeef to amend PR #500 to remove the static definition or open a new PR to do that
    2. roasbeef to help with the wording of the PR to remove any remaining uncertainty
  4. sstone
    1. sstone to rework #519 with the feedback on the PR
    2. sstone to merge #538
    3. sstone to rephrase the PR to include what to do when type is unknown, everybody to discuss lively on the PR
  5. UNASSIGNED
    1. The test vectors in #539 need to be verified independently. Decision is to be deferred until the next meeting
    2. Defer #552 to the tracker


People present (lines said)

  1. cdecker (126)
  2. roasbeef (73)
  3. BlueMatt (42)
  4. sstone (30)
  5. bitconner (27)
  6. lndbot (13)
  7. rusty (6)
  8. lightningbot (2)
  9. kanzure (1)


Generated by MeetBot 0.1.4.