#lightning-dev Meeting

Meeting started by cdecker at 19:00:17 UTC (full logs).

Meeting summary

    1. Agenda for today can be found here https://github.com/lightningnetwork/lightning-rfc/issues/574 (cdecker, 19:00:47)

  1. Tagging v1.0 (cdecker, 19:04:16)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/570 Is so nice, I (somehow) acked it twice! (rusty, 19:04:36)
    2. https://github.com/lightningnetwork/lightning-rfc/milestone/2 (rusty, 19:05:04)
    3. AGREED: cdecker to merge PR #570 (cdecker, 19:08:08)
    4. AGREED: rusty to tag v1.0 after merging #570 (cdecker, 19:09:59)

  2. PR #539: BOLT 3: add test vectors for htlc-transactions in case where CLTV is used as tie-breaker for sorting (cdecker, 19:10:36)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/539 (cdecker, 19:10:45)
    2. ACTION: rusty to validate PR 539 test vectors. (rusty, 19:12:05)
    3. AGREED: everybody to aim for machine-readable test-vectors (in JSON) (cdecker, 19:14:04)

  3. PR #571 Feature bit unification and assignment (cdecker, 19:16:34)
    1. AGREED: everyone to bikeshed on #571 a bit more (cdecker, 19:41:38)

  4. PR #572 Specify tlv format, initial MPP (cdecker, 19:41:58)
    1. AGREED: everybody to weigh in on the discussion of PR #572 (cdecker, 19:58:19)

  5. SURBs as a Solution for Protocol-Level Payment ACKs (cdecker, 19:58:42)
    1. AGREED: everybody to discuss SURBS on the mailing list (cdecker, 20:14:54)


Meeting ended at 20:15:38 UTC (full logs).

Action items

  1. rusty to validate PR 539 test vectors.


Action items, by person

  1. rusty
    1. rusty to validate PR 539 test vectors.


People present (lines said)

  1. cdecker (96)
  2. roasbeef (76)
  3. rusty (75)
  4. bitconner (11)
  5. sstone (6)
  6. araspitzu (4)
  7. lightningbot (2)
  8. niftynei (2)
  9. lndbot (2)
  10. Chris_Stewart_5 (2)
  11. BlueMatt (1)
  12. kanzure (1)


Generated by MeetBot 0.1.4.