19:02:14 <rusty> #startmeeting
19:02:14 <lightningbot> Meeting started Mon Mar 18 19:02:14 2019 UTC.  The chair is rusty. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:14 <lightningbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:20 <kanzure> hi
19:02:23 <rusty> #info https://github.com/lightningnetwork/lightning-rfc/issues/588
19:02:40 <Chris_Stewart_5> Might be sparsely attended for US folks since we had our daylight savings last week
19:03:11 <rusty> Agenda is suspiciously light... Ah, thanks Chris_Stewart_5, we're going to hit a second DST event soon when I move off DST, as well.
19:03:14 <Chris_Stewart_5> wall clock time is an hour later for us now
19:03:51 <rusty> Then errors should cause people to be bright and early, which is better than coming in at the end!
19:04:00 <rusty> sstone: hi!
19:04:03 <sstone> hi!
19:04:04 <lndbot> <johanth> hi :slightly_smiling_face:
19:04:57 <niftynei> hello!
19:05:22 <rusty> roasbeef suggested we split up option_simplified_commitment, and I posted that to the ML.  I think I actually have implemented it already (except I need to use the new feature bit).  I have also started implementing the extended gossip queries.
19:05:46 <rusty> Since cdecker is at a fireside chat instead, seems a productive place to start.
19:06:38 <rusty> Anyone have any feedback on the concept of option_static_remotekey as I called it?
19:07:05 <rusty> https://lists.linuxfoundation.org/pipermail/lightning-dev/2019-March/001911.html
19:08:57 <rusty> The only caveat is that we may end up renaming option_simplified_commitment into option_bring_your_own_fees, since that's what's left (and we may make it require or imply option_static_remotekey to avoid testing all options).
19:09:59 <sstone> we like option_static_remotekey too. we've already started implementing "simplified commitment tx" and should be able to extract what is needed.
19:10:52 <rusty> sstone: great; yeah, it is kind of the easy part.  I guess the debate was whether to include symmetric CSV delays under that feature, but it was easy to implement and related, so I chose to.
19:11:37 <sstone> Yes I think we need to
19:11:45 <rusty> sstone: sorry I have been remiss on implementing the gossip enhancements, but I finally started last night and it was *really easy*, so I expect quick progress from here.  I'll test my node against yours today.
19:12:25 <sstone> we'll add test vectors (in JSON format :))
19:12:44 <rusty> sstone: I need to get back to that, yes.... so much to do, so little time!
19:13:26 <rusty> Anyone else have things to bring up, otherwise a short meeting is a good meeting?  Though I think roasbeef and bitconner are sleeping :)
19:14:53 <rusty> BTW: we have an intern Joe making progress generating the Million Channels Project, and it's caused me to have to actually implement some optimizations so it doesn't take forever to benchmark, let alone give decent results so that's been my 2 weeks...
19:15:15 <sstone> I've add a look at Christian's proposal for "framing" the onion and I think it's quite nice and simple but maybe pointless to discuss without him and roaseef ?
19:15:36 <rusty> sstone: yes, agreed.  I like it too, but I want them to sort it out :)
19:17:05 <sstone> yes :) did you have time to check the test vectors for the CLTV-based sorting of HTLCs ?
19:17:33 <rusty> #action rusty to check CLTV-sorting HTLC vectors
19:19:23 <rusty> Three minor notes:  1. I've created a tag for "Next Meeting" for people to note stuff they want to raise; I'll clear it from all issues at the end of each meeting, rahter than a specific per-meeting tag.  Please use.  2. DST is going to move 7 April, so the meeting will move +1 hr again then (that's *not* nxt meeting, but the following).  3. Mailing list is movign to groups.io, you don't need to do anything if you want to be subsc
19:19:23 <rusty> ribed to the new one.
19:19:28 <roasbeef> static key FTW
19:19:39 <roasbeef> reading mail for the first time now ;)
19:19:52 <rusty> roasbeef: cool :)
19:20:22 <rusty> roasbeef: gives us more breathing room with standardness rules etc for bitcoin propagation.
19:20:35 <roasbeef> i also have a few things to add to the DLP section bsaed on some work we've done in lnd within that area, some recovery edge cases
19:20:38 <roasbeef> def
19:21:05 <roasbeef> what time zone do we base the meeting off rn? AU?
19:21:10 <roasbeef> DST happened in teh us already
19:21:33 <roasbeef> is the groups.io interface very diff than the old linux foundation one?
19:21:35 <rusty> roasbeef: great.  Yes, it's in a link in the issue https://github.com/lightningnetwork/lightning-rfc/issues/588 and I always update it.
19:21:40 <roasbeef> also what will happen to the existing archives?
19:22:07 <rusty> roasbeef: I believe the existing archives will be maintained, though I'll be seeking a mirror just in case.
19:22:43 <rusty> roasbeef: groups.io put an obnoxious tailer on messages with unsubscribe links etc, but that seems to be about it.
19:23:07 <roasbeef> gotcha, was google groups out of the question?
19:23:15 <roasbeef> jw
19:24:15 <rusty> roasbeef: LF are migrating all lists to groups.io; I have a real, active, listserver we could have moved to (lists.ozlabs.org) which hosts some non-trivial lists, but since they're doing this for us, I thought it the easiest path.
19:25:41 <rusty> OK, unless people have other issues to discussion, I'm going to end meeting?
19:27:02 <rusty> #endmeeting