#lightning-dev Meeting

Meeting started by cdecker at 20:05:24 UTC (full logs).

Meeting summary

    1. (t-bast, 20:05:55)

  1. BOLT7: extend channel range queries with optional fields #557 (cdecker, 20:07:41)
  2. Specify tlv format, initial MPP #572 (cdecker, 20:33:07)
    1. AGREED: The TPV types need to be message-specific, not global like in the current proposal, to maintain flexibility (cdecker, 20:44:37)
    2. AGREED: Discussion of whether the even/odd rule should apply to TLV types as well is deferred to the ML/issue tracker (cdecker, 20:45:08)

  3. bolt04: Multi-frame sphinx onion routing proposal #593 (cdecker, 20:50:30)
    1. ACTION: cdecker to assign a node_announcement feature bit to signal multi-frame support in the gossip (cdecker, 21:01:40)
    2. ACTION: cdecker to add multi-frame test-vector (cdecker, 21:19:47)

  4. BOLT2: rephrase cltv_expiry_delta text about accepting HTLCs #595 (cdecker, 21:20:09)
    1. ACTION: cdecker merged #595, based on decision from last meeting (cdecker, 21:20:57)

  5. BOLT 5: Homogenize Local/Remote Commitment #598 (cdecker, 21:21:23)
    1. AGREED: cdecker to merge #598 (cdecker, 21:23:19)

  6. BOLT 3: Explicit description of implicitly enforced timelocks on HTLC outputs #601 (cdecker, 21:24:20)
    1. ACTION: cdecker to add a bit more detail about how the timelock is committed to in the signature (cdecker, 21:27:46)

  7. Chit chat and gossip :-) (cdecker, 21:28:12)


Meeting ended at 21:32:03 UTC (full logs).

Action items

  1. cdecker to assign a node_announcement feature bit to signal multi-frame support in the gossip
  2. cdecker to add multi-frame test-vector
  3. cdecker merged #595, based on decision from last meeting
  4. cdecker to add a bit more detail about how the timelock is committed to in the signature


Action items, by person

  1. cdecker
    1. cdecker to assign a node_announcement feature bit to signal multi-frame support in the gossip
    2. cdecker to add multi-frame test-vector
    3. cdecker merged #595, based on decision from last meeting
    4. cdecker to add a bit more detail about how the timelock is committed to in the signature


People present (lines said)

  1. cdecker (135)
  2. bitconner (49)
  3. t-bast (40)
  4. roasbeef (29)
  5. niftynei (16)
  6. lightningbot (2)
  7. m-schmoock (2)


Generated by MeetBot 0.1.4.