#lightning-dev Meeting

Meeting started by roasbeef at 20:03:03 UTC (full logs).

Meeting summary

  1. #609: unify redundant paragraphs (roasbeef, 20:06:34)
    1. ACTION: merge 609 (roasbeef, 20:07:53)

  2. 608 merge final expiry and unknown payment hash (roasbeef, 20:08:25)
    1. AGREED: circle back on #608 next week (roasbeef, 20:23:30)

  3. #607 and #603 (roasbeef, 20:23:42)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/607 (roasbeef, 20:24:19)
    2. https://github.com/lightningnetwork/lightning-rfc/pull/603 (roasbeef, 20:24:23)
    3. AGREED: discuss #603 and #607 on PR, open q's to resolve: if distinct wire and onion, and if even/odd should apply to all (or just one if unified), requirements for decoder, <insert other tradeoffs here> (roasbeef, 20:43:41)

  4. 606 (roasbeef, 20:43:46)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/606 (roasbeef, 20:43:57)
    2. ACTION: merge #606 (roasbeef, 20:46:02)

  5. #601 (roasbeef, 20:46:14)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/601 (roasbeef, 20:46:20)
    2. ACTION: roasbeef to comment on #601 about bolt2 portion of diff (roasbeef, 20:51:12)

  6. #604 and #593 (roasbeef, 20:51:50)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/604 (roasbeef, 20:51:56)
    2. https://github.com/lightningnetwork/lightning-rfc/pull/593 (roasbeef, 20:52:02)
    3. ACTION: wait for comments/feedback from rusty w.r.t #593 vs #604 on PR (roasbeef, 21:27:58)


Meeting ended at 21:30:31 UTC (full logs).

Action items

  1. merge 609
  2. merge #606
  3. roasbeef to comment on #601 about bolt2 portion of diff
  4. wait for comments/feedback from rusty w.r.t #593 vs #604 on PR


Action items, by person

  1. roasbeef
    1. roasbeef to comment on #601 about bolt2 portion of diff
  2. UNASSIGNED
    1. merge 609
    2. merge #606
    3. wait for comments/feedback from rusty w.r.t #593 vs #604 on PR


People present (lines said)

  1. roasbeef (121)
  2. cdecker (70)
  3. bitconner (49)
  4. t-bast (35)
  5. sstone (13)
  6. niftynei (9)
  7. lndbot (7)
  8. jtimon (6)
  9. lightningbot (2)


Generated by MeetBot 0.1.4.