#lightning-dev Meeting

Meeting started by cdecker at 20:02:38 UTC (full logs).

Meeting summary

    1. https://github.com/lightningnetwork/lightning-rfc/projects/1 (cdecker, 20:04:27)

  1. Resuming video-chat spec meetings in parallel to the IRC meetings (cdecker, 20:05:38)
  2. bolt04: Variable `hop_payload` for the sphinx onion #619 (cdecker, 20:11:22)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/619 (cdecker, 20:11:24)
    2. ACTION: cdecker to fix typos in PR #619 and add the route termination TLV value to spec (cdecker, 20:24:46)
    3. ACTION: conner to ask roasbeef for an ACK on the PR (cdecker, 20:25:00)
    4. AGREED: cdecker good to merge #619 once fixes are in and roasbeef ACKd (cdecker, 20:25:20)

  3. BOLT01: TLV proposal #607 (cdecker, 20:26:37)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/607 (cdecker, 20:26:44)
    2. AGREED: Merge #607 (cdecker, 20:42:12)
    3. https://github.com/lightningnetwork/lightning-rfc/pull/557 (t-bast, 20:44:00)

  4. BOLT7: extend channel range queries with optional fields #557 (cdecker, 20:44:12)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/557 (cdecker, 20:44:19)
    2. AGREED: Merge #557 once we have a second implementation (cdecker, 20:52:24)

  5. Single-option large channel proposal #596 (cdecker, 20:54:18)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/596 (cdecker, 20:54:24)
    2. https://github.com/lightningnetwork/lightning-rfc/issues/605 (rusty, 21:00:23)
    3. https://github.com/lightningnetwork/lightning-rfc/pull/571/commits/14ced3b6c33961f1adc3699994c21a4abc4958f8 (rusty, 21:06:14)
    4. AGREED: Defer PR #571 to the ML and tracker, to be decided during the next meeting (cdecker, 21:08:57)

  6. Chit-chat and announcements (cdecker, 21:09:12)


Meeting ended at 21:13:53 UTC (full logs).

Action items

  1. cdecker to fix typos in PR #619 and add the route termination TLV value to spec
  2. conner to ask roasbeef for an ACK on the PR


Action items, by person

  1. cdecker
    1. cdecker to fix typos in PR #619 and add the route termination TLV value to spec


People present (lines said)

  1. cdecker (112)
  2. rusty (55)
  3. t-bast (53)
  4. lndbot (47)
  5. sstone (11)
  6. lightningbot (2)
  7. kanzure (2)


Generated by MeetBot 0.1.4.