#lightning-dev Meeting

Meeting started by niftynei at 20:04:28 UTC (full logs).

Meeting summary

  1. #640 swap CompactSize for BigSize in TLV format (niftynei, 20:06:45)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/640 (cdecker, 20:06:55)
    2. AGREED: merging #640 (niftynei, 20:10:05)
    3. ACTION: cdecker to lead bikeshedding on externalizing and neatening test vectors. (rusty, 20:10:08)

  2. TLV testcases #631 (niftynei, 20:11:15)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/631#pullrequestreview-260999156 (rusty, 20:14:40)
    2. ACTION: merge #631 (niftynei, 20:15:32)

  3. variable sized onion payloads https://github.com/lightningnetwork/lightning-rfc/pull/619 (niftynei, 20:17:21)
    1. AGREED: eliminate 0 TLV record for now (niftynei, 20:29:16)
    2. ACTION: roasbeef to ack test vectors (niftynei, 20:29:24)
    3. https://github.com/lightningnetwork/lightning-rfc/pull/627 (t-bast, 20:31:06)

  4. BOLT 04: Add failure code for invalid payload (niftynei, 20:32:38)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/627 (niftynei, 20:32:52)
    2. ACTION: rusty to leave feedback on PR (niftynei, 20:36:48)

  5. BOLT7: (announcement_signatures) Fail channel if `short_channel_id` not correct. #635 (niftynei, 20:37:56)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/635 (niftynei, 20:38:00)
    2. https://github.com/lightningnetwork/lightning-rfc/pull/635 (niftynei, 20:38:03)
    3. ACTION: upgrade from MAY to SHOULD (niftynei, 20:39:00)
    4. AGREED: MAY be merged after SHOULD updated (niftynei, 20:40:26)

  6. BOLT 2: remove local/remote from reestablish field names. (niftynei, 20:41:13)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/634 (niftynei, 20:41:19)
    2. AGREED: merge #634 (niftynei, 20:43:06)

  7. option_data_loss_protect: concretely define `my_current_per_commitment_point` (niftynei, 20:43:45)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/550 (niftynei, 20:44:09)
    2. ACTION: roasbeef to check outstanding comment (niftynei, 20:50:34)

  8. CONTRIBUTING.md: first draft of how to write and change spec. #651 (niftynei, 20:53:37)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/651 (niftynei, 20:53:49)
    2. AGREED: one week for feedback, once resolved ok for approval (niftynei, 20:57:51)

  9. BOLT7: extend channel range queries with optional fields #557 (niftynei, 20:58:12)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/557 (niftynei, 20:58:20)
    2. ACTION: to continue discussion on PR, CL to re-do implementation (niftynei, 21:09:28)

  10. next meeting chair? (niftynei, 21:09:53)
    1. ACTION: niftynei to untag every Meeting Discussion label (so they can be re-added for next meeting) (niftynei, 21:14:39)
    2. AGREED: bitconner nominated to chair next meeting, t-bast will serve as backup chair (niftynei, 21:16:04)


Meeting ended at 21:16:17 UTC (full logs).

Action items

  1. cdecker to lead bikeshedding on externalizing and neatening test vectors.
  2. merge #631
  3. roasbeef to ack test vectors
  4. rusty to leave feedback on PR
  5. upgrade from MAY to SHOULD
  6. roasbeef to check outstanding comment
  7. to continue discussion on PR, CL to re-do implementation
  8. niftynei to untag every Meeting Discussion label (so they can be re-added for next meeting)


Action items, by person

  1. cdecker
    1. cdecker to lead bikeshedding on externalizing and neatening test vectors.
  2. niftynei
    1. niftynei to untag every Meeting Discussion label (so they can be re-added for next meeting)
  3. roasbeef
    1. roasbeef to ack test vectors
    2. roasbeef to check outstanding comment
  4. rusty
    1. rusty to leave feedback on PR
  5. UNASSIGNED
    1. merge #631
    2. upgrade from MAY to SHOULD
    3. to continue discussion on PR, CL to re-do implementation


People present (lines said)

  1. t-bast (86)
  2. niftynei (78)
  3. rusty (62)
  4. roasbeef (53)
  5. cdecker (45)
  6. sstone (10)
  7. ianthius (4)
  8. jtimon (3)
  9. lightningbot (2)
  10. lndbot (1)


Generated by MeetBot 0.1.4.