#lightning-dev Meeting

Meeting started by roasbeef at 20:11:44 UTC (full logs).

Meeting summary

  1. #658 and #643 (mpp and amp drafts) (roasbeef, 20:12:29)
    1. ACTION: rebase #643 on master, continue discussion of #658 and #643 on github, to bubble up in the meeting as needed (roasbeef, 20:39:52)

  2. 657 (roasbeef, 20:40:31)
    1. ACTION: connder to fine new home for announcement_signatures (bitconner, 20:47:30)
    2. ACTION: #657 to have wording clarified on PR (roasbeef, 20:51:30)

  3. 656 (roasbeef, 20:51:51)
    1. ACTION: general acceptance of #656, to hash out on PR (roasbeef, 20:54:29)

  4. #577 (range queries) (roasbeef, 20:54:47)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/557 (t-bast, 20:55:02)
    2. CL and eclair working on interop, CL working on further tests then can start (roasbeef, 21:03:26)
    3. ACTION: 577 mostly reeady to go, gated on interop tests between CL and eclair, lnd to follow later (but not blocking) (roasbeef, 21:03:49)
    4. ACTION: s/577/557/ (niftynei, 21:05:26)

  5. #642 (static remote key) (roasbeef, 21:05:34)
    1. ACTION: stick with only feature bit on #642, next steps are interop (roasbeef, 21:20:20)

  6. 627 (roasbeef, 21:20:28)
    1. ACTION: possibly add type+length offset to #627, need of some sort is clear (roasbeef, 21:27:52)


Meeting ended at 23:02:51 UTC (full logs).

Action items

  1. rebase #643 on master, continue discussion of #658 and #643 on github, to bubble up in the meeting as needed
  2. connder to fine new home for announcement_signatures
  3. #657 to have wording clarified on PR
  4. general acceptance of #656, to hash out on PR
  5. 577 mostly reeady to go, gated on interop tests between CL and eclair, lnd to follow later (but not blocking)
  6. s/577/557/
  7. stick with only feature bit on #642, next steps are interop
  8. possibly add type+length offset to #627, need of some sort is clear


People present (lines said)

  1. roasbeef (138)
  2. t-bast (94)
  3. bitconner (57)
  4. rusty (40)
  5. BlueMatt (27)
  6. cdecker (24)
  7. lndbot (12)
  8. niftynei (10)
  9. sstone (5)
  10. lightningbot (2)


Generated by MeetBot 0.1.4.