20:09:08 <bitconner> #startmeeting
20:09:08 <lightningbot> Meeting started Mon Sep 16 20:09:08 2019 UTC.  The chair is bitconner. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:09:08 <lightningbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:09:13 <rusty> ... still asking (someone?) to join hangout apparently...
20:10:12 <t-bast> censorship? in this space? how can that be
20:12:13 <bitconner> #topic static remote key https://github.com/lightningnetwork/lightning-rfc/pull/642
20:18:53 <t-bast> am I the only one that hear only half what conner says?
20:19:04 <sstone> same here
20:19:54 <rusty> ARguing over game theory at the moment.  Symmetry is better, but the conditions where you want to game the peer into closing is pretty narrow: if you can talk to them, you can just shutdown.  If you can't, it's hard to make them unilateral close.
20:21:47 <bitconner> slow internetz, sorry :(
20:23:10 <t-bast> no problem, we'll interpolate the missing parts ;)
20:24:11 <rusty> bitconner reports roasbeef says c-lightning interop worked.  W00t!
20:29:16 <rusty> Seems consensus is that option_simplified_commitment should consider symmetry for CSV (with constrained set of allowed CSV values).
20:29:25 <bitconner> #agreed push static remote key through as is, defer discussion of csv to option simplified commitment
20:30:22 <bitconner> #agree to merge pending roasbeef
20:30:26 <t-bast> ACK
20:30:31 <cdecker> ACK
20:30:48 <rusty> ack!!
20:31:18 <sstone> ack :)
20:32:04 <bitconner> #topic extending gossip queries https://github.com/lightningnetwork/lightning-rfc/pull/557
20:32:24 <bitconner> ack
20:33:19 <rusty> ack!
20:34:34 <t-bast> ack
20:36:11 <rusty> w00t!
20:36:48 <bitconner> #agree merge!!!!
20:37:18 <bitconner> #agreed mergee!!!
20:37:34 <t-bast> yay!
20:38:26 <bitconner> #topic flat feature bits https://github.com/lightningnetwork/lightning-rfc/pull/666
20:41:35 <roasbeef> rusty: re csv, we already stripped down the proposal to be as minimal as posisble so we can deploy
20:41:44 <bitconner> concept ACK, lprevent feature bit collision and can retroactively modify where feature bits are advertised
20:41:47 <rusty> roasbeef: agreed.
20:42:17 <rusty> bitconner: OK, will change mbz to allow non-zero, but mark it deprecated.
20:42:19 <bitconner> roasbeef, yeah we agreed to defer csv discussion to simplified commitment
20:42:33 <t-bast> ACK on #666, pending the change to allow for non-0 global features since master branches of eclair and lnd currently advertize it
20:42:44 <rusty> (Eclair and LND advertize global today in init in their master)
20:43:35 <roasbeef> what's teh feature bit change?
20:44:01 <t-bast> flattening everything
20:44:12 <t-bast> not separating between local / global
20:44:14 <bitconner> enforce that global features in init  should always be zero-length, and put them all in current local field
20:44:27 <rusty> roasbeef: single feature field in init, each feature  decides how and where it's advertized (init, node_announcement, channel_announcement).
20:47:09 <roasbeef> must this be done before rolling out the static key commitmetn stuff? feels liek it'll delay the deployment of a pretty critical safety improvement even further
20:47:37 <rusty> roasbeef: doesn't affect it AFAICT?
20:47:42 <roasbeef> this is mostly cosmetic
20:47:46 <roasbeef> well it would become a dep
20:47:54 <bitconner> #action continue work on PR, general agreement with direction
20:48:28 <bitconner> #topic base amp https://github.com/lightningnetwork/lightning-rfc/pull/643
20:53:01 <bitconner> all payments in the future will be amp or mpp payments and being dprecating current style of single-shot payments
20:53:20 <t-bast> agreed
20:53:34 <bitconner> allows bundling of invoice secret into mpp proposal and invoice changes
20:53:51 <bitconner> amp tlv payloads can just be a further extension of mpp fields
20:53:52 <t-bast> SGTM, feel free to rename it too, I just wanted to get the ball rolling on adding that field
20:54:07 <rusty> Yep, so the same feature bit means both.  Also spec should spell out the implication that it means the final node accepts TLV, even if you didn't see a node_announcement.
21:03:00 <bitconner> #action rusty to think through overpayment scenarios
21:03:26 <rusty> Discussion was on whether we want to keep fuzzing amounts with MPP or not..
21:04:44 <rusty> #action rusty to rebase 643
21:06:58 <rusty> Note: Propose meeting in 4 weeks moved earlier a few days, to 5pm Friday Berlin time, so we can do this face-to-face at TheLightningConference.com.
21:10:38 <bitconner> #action continue discussion of single tlv or split on pr
21:10:45 <bitconner> #endmeeting