#lightning-dev Meeting

Meeting started by roasbeef at 19:10:32 UTC (full logs).

Meeting summary

    1. ACTION: merged #660 (roasbeef, 19:11:49)

  1. 571 (feature bit renaming) (roasbeef, 19:14:01)
    1. ACTION: rusty to update #666 after latest round of comments and meatspace discussion (roasbeef, 19:16:50)

  2. 596 wumbo bit for channels (roasbeef, 19:17:21)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/596 (roasbeef, 19:17:47)
    2. 596 has dep on 666, needs to be rebased as well once 666 is in (roasbeef, 19:19:10)

  3. 620 (roasbeef, 19:19:24)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/620 (roasbeef, 19:19:31)
    2. clarification on message placement in bolts (ann sig) (roasbeef, 19:19:55)

  4. 625 (roasbeef, 19:35:14)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/625 (roasbeef, 19:35:21)

  5. 658 (amp) (roasbeef, 19:45:33)
  6. #643 (mpp) (roasbeef, 19:45:47)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/643 (roasbeef, 19:45:55)
    2. payload now combines payment addr and total amt (roasbeef, 19:46:57)
    3. review to continue on PR, aiming to catch merge train in 2 weeks (roasbeef, 19:48:23)

  7. 658 (amp) (roasbeef, 19:48:39)
    1. ACTION: paylaods now unified, conner to update PR to reflect new paylaod structure (roasbeef, 19:49:09)

  8. 671 (invoice secret) (roasbeef, 19:49:33)
    1. ACTION: 671 to clarify being able to signal for mpp (can combine) and just presence of secret that must be included (e2e security for donation case) (roasbeef, 20:02:42)

  9. 682 (roasbeef, 20:08:15)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/682 (roasbeef, 20:08:20)
    2. ACTION: wait on input from conner to clarify comments (roasbeef, 20:11:26)

  10. 688 (roasbeef, 20:11:43)
    1. anchor outputs (roasbeef, 20:11:48)
    2. https://github.com/lightningnetwork/lightning-rfc/pull/688 (roasbeef, 20:11:57)


Meeting ended at 20:23:12 UTC (full logs).

Action items

  1. merged #660
  2. rusty to update #666 after latest round of comments and meatspace discussion
  3. paylaods now unified, conner to update PR to reflect new paylaod structure
  4. 671 to clarify being able to signal for mpp (can combine) and just presence of secret that must be included (e2e security for donation case)
  5. wait on input from conner to clarify comments


Action items, by person

  1. rusty
    1. rusty to update #666 after latest round of comments and meatspace discussion
  2. UNASSIGNED
    1. merged #660
    2. paylaods now unified, conner to update PR to reflect new paylaod structure
    3. 671 to clarify being able to signal for mpp (can combine) and just presence of secret that must be included (e2e security for donation case)
    4. wait on input from conner to clarify comments


People present (lines said)

  1. roasbeef (140)
  2. rusty (56)
  3. joostjgr (22)
  4. cdecker (19)
  5. sstone (8)
  6. niftynei (5)
  7. lightningbot (2)


Generated by MeetBot 0.1.4.