#lightning-dev Meeting

Meeting started by t-bast at 19:05:45 UTC (full logs).

Meeting summary

  1. Message extensions (t-bast, 19:06:39)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/705 (t-bast, 19:06:43)
    2. ACTION: t-bast update the wording on "random" choice (t-bast, 19:11:43)
    3. ACTION: t-bast create a wiki or issue to track used message IDs (t-bast, 19:12:02)

  2. Message TLV extensions (t-bast, 19:12:33)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/714 (t-bast, 19:12:36)
    2. ACTION: t-bast add proposal on how to handle current optional fields (probably make them all mandatory) (t-bast, 19:33:31)
    3. ACTION: t-bast remove the length prefix (t-bast, 19:33:37)
    4. ACTION: all keep thinking about ways to clean-up the spec (t-bast, 19:33:56)

  3. https://github.com/lightningnetwork/lightning-rfc/pull/641 (t-bast, 19:43:06)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/641 (t-bast, 19:43:10)
    2. ACTION: keep discussing on the PR to summarize pros and cons (t-bast, 19:59:30)

  4. Anchor Outputs (t-bast, 19:59:43)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/688 (t-bast, 19:59:46)
    2. https://meet.google.com/vyt-qnjg-bnm?pli=1&authuser=0 (t-bast, 19:59:55)
    3. ACK on the scripts with small changes (CLTV=16) (t-bast, 20:27:41)
    4. ACK on using a symmetric delay with max (using current negotiation) (t-bast, 20:27:58)
    5. leaning more towards a constant value for the anchor outputs (t-bast, 20:37:00)


Meeting ended at 20:37:10 UTC (full logs).

Action items

  1. t-bast update the wording on "random" choice
  2. t-bast create a wiki or issue to track used message IDs
  3. t-bast add proposal on how to handle current optional fields (probably make them all mandatory)
  4. t-bast remove the length prefix
  5. all keep thinking about ways to clean-up the spec
  6. keep discussing on the PR to summarize pros and cons


Action items, by person

  1. t-bast
    1. t-bast update the wording on "random" choice
    2. t-bast create a wiki or issue to track used message IDs
    3. t-bast add proposal on how to handle current optional fields (probably make them all mandatory)
    4. t-bast remove the length prefix
  2. UNASSIGNED
    1. all keep thinking about ways to clean-up the spec
    2. keep discussing on the PR to summarize pros and cons


People present (lines said)

  1. t-bast (80)
  2. bitconner (38)
  3. cdecker (38)
  4. rusty (32)
  5. roasbeef (29)
  6. BlueMatt (13)
  7. niftynei (8)
  8. sstone_ (6)
  9. joostjgr (5)
  10. lightningbot (2)


Generated by MeetBot 0.1.4.