#lightning-dev Meeting

Meeting started by cdecker at 19:06:59 UTC (full logs).

Meeting summary

    1. https://github.com/lightningnetwork/lightning-rfc/issues/731 (cdecker, 19:07:25)
    2. ACTION: t-bast: implement proposed mitigation for #728 and document that (t-bast, 19:11:11)

  1. Single-option large channel proposal #596 (cdecker, 19:12:29)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/596 (cdecker, 19:12:36)
    2. ACTION: cdecker to change the featurebits to 18/19 and merge #596 (cdecker, 19:20:24)
    3. ACTION: t-bast and araspitzu to brainstorm an advisory section in a new PR explaining how confirmations should scale with the funding amount (cdecker, 19:21:56)

  2. BOLT 7: be more aggressive about sending our own gossip. #684 (cdecker, 19:28:10)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/684 (cdecker, 19:28:22)
    2. ACTION: cdecker to rebase and merge #684 (cdecker, 19:32:03)

  3. Bolt 1: Specify that extensions to existing messages must use TLV #714 (@t-bast) (cdecker, 19:33:05)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/714 (cdecker, 19:33:16)
    2. ACTION: everyone to continue the discussion of #714 on GH (cdecker, 19:48:12)

  4. BOLT7: reply_channel_range parameter #560 (cdecker, 19:48:54)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/560 (cdecker, 19:49:02)
    2. ACTION: everyone to discuss the minutiae of #560 and #730 on GH (cdecker, 20:05:41)

  5. Current status of the trampoline routing proposal (@t-bast) (cdecker, 20:06:25)
    1. ACTION: rusty to rework 560 and 730 to assume ascending order. (rusty, 20:06:34)

  6. Current state of the anchor output proposal (@joostjager) (cdecker, 20:07:10)
    1. ACTION: everyone to keep an eye on the anchor outputs proposal and help wherever possible :-) (cdecker, 20:28:49)


Meeting ended at 20:32:39 UTC (full logs).

Action items

  1. t-bast: implement proposed mitigation for #728 and document that
  2. cdecker to change the featurebits to 18/19 and merge #596
  3. t-bast and araspitzu to brainstorm an advisory section in a new PR explaining how confirmations should scale with the funding amount
  4. cdecker to rebase and merge #684
  5. everyone to continue the discussion of #714 on GH
  6. everyone to discuss the minutiae of #560 and #730 on GH
  7. rusty to rework 560 and 730 to assume ascending order.
  8. everyone to keep an eye on the anchor outputs proposal and help wherever possible :-)


Action items, by person

  1. araspitzu
    1. t-bast and araspitzu to brainstorm an advisory section in a new PR explaining how confirmations should scale with the funding amount
  2. cdecker
    1. cdecker to change the featurebits to 18/19 and merge #596
    2. cdecker to rebase and merge #684
  3. rusty
    1. rusty to rework 560 and 730 to assume ascending order.
  4. t-bast
    1. t-bast: implement proposed mitigation for #728 and document that
    2. t-bast and araspitzu to brainstorm an advisory section in a new PR explaining how confirmations should scale with the funding amount
  5. UNASSIGNED
    1. everyone to continue the discussion of #714 on GH
    2. everyone to discuss the minutiae of #560 and #730 on GH
    3. everyone to keep an eye on the anchor outputs proposal and help wherever possible :-)


People present (lines said)

  1. cdecker (95)
  2. t-bast (84)
  3. roasbeef (66)
  4. BlueMatt (50)
  5. rusty (49)
  6. joostjgr (21)
  7. niftynei (8)
  8. sstone (7)
  9. araspitzu (4)
  10. lightningbot (2)


Generated by MeetBot 0.1.4.