#lightning-dev Meeting

Meeting started by niftynei at 20:08:05 UTC (full logs).

Meeting summary

    1. https://github.com/lightningnetwork/lightning-rfc/issues/768 (niftynei, 20:09:06)

  1. stuck channels #740 (niftynei, 20:10:02)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/740 (niftynei, 20:10:16)
    2. ACTION: t-bast to squash/merge PR #740 for stuck channels (niftynei, 20:16:43)

  2. PR #767 prune channels with old channel_updates (niftynei, 20:17:32)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/767 (niftynei, 20:17:34)
    2. ACTION: rusty to figure out c-lightning pruning reality (niftynei, 20:33:30)
    3. ACTION: discussion for PR 768 to continue on github (niftynei, 20:33:42)

  3. issue 761, which is a discussion branched off of 740 (niftynei, 20:34:44)
    1. https://github.com/lightningnetwork/lightning-rfc/issues/761 (niftynei, 20:34:44)
    2. ACTION: roasbeef to check thread out (niftynei, 20:39:44)
    3. "it's the nature of the beast" - rusty (niftynei, 20:40:02)

  4. long term updates: blinded paths cc t-bast (niftynei, 20:42:35)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/765 (t-bast, 20:43:32)
    2. ACTION: t-bast to investigate making fee/cltv uniform in the blinded path, describe that in the PR (t-bast, 20:59:39)
    3. ACTION: discussion to continue on PR (niftynei, 21:05:08)

  5. long term updates: mempool tx pinning attack cc ariad & BlueMatt (niftynei, 21:05:40)
    1. https://github.com/bitcoinops/bitcoinops.github.io/pull/394/files (ariard, 21:06:55)
    2. https://lists.linuxfoundation.org/pipermail/bitcoin-dev/2020-April/017757.html ... (rusty, 21:07:13)
    3. https://lists.linuxfoundation.org/pipermail/lightning-dev/2020-April/002639.html (niftynei, 21:07:44)
    4. https://lists.linuxfoundation.org/pipermail/bitcoin-dev/2020-April/017757.html (niftynei, 21:08:07)
    5. ttps://github.com/bitcoinops/bitcoinops.github.io/pull/394/files (niftynei, 21:09:00)
    6. https://github.com/bitcoinops/bitcoinops.github.io/pull/394/files (niftynei, 21:09:10)
    7. ACTION: amend anchors to make no changes to htlc signatures, and resolve the other issues (needs tests cases, debate about 1-vs-2 etc) on the ml or issue (niftynei, 21:19:22)
    8. ACTION: work on redoing things to use anchors (maybe based on feerates) in htlc txn (niftynei, 21:19:32)


Meeting ended at 21:21:36 UTC (full logs).

Action items

  1. t-bast to squash/merge PR #740 for stuck channels
  2. rusty to figure out c-lightning pruning reality
  3. discussion for PR 768 to continue on github
  4. roasbeef to check thread out
  5. t-bast to investigate making fee/cltv uniform in the blinded path, describe that in the PR
  6. discussion to continue on PR
  7. amend anchors to make no changes to htlc signatures, and resolve the other issues (needs tests cases, debate about 1-vs-2 etc) on the ml or issue
  8. work on redoing things to use anchors (maybe based on feerates) in htlc txn


Action items, by person

  1. roasbeef
    1. roasbeef to check thread out
  2. rusty
    1. rusty to figure out c-lightning pruning reality
  3. t-bast
    1. t-bast to squash/merge PR #740 for stuck channels
    2. t-bast to investigate making fee/cltv uniform in the blinded path, describe that in the PR
  4. UNASSIGNED
    1. discussion for PR 768 to continue on github
    2. discussion to continue on PR
    3. amend anchors to make no changes to htlc signatures, and resolve the other issues (needs tests cases, debate about 1-vs-2 etc) on the ml or issue
    4. work on redoing things to use anchors (maybe based on feerates) in htlc txn


People present (lines said)

  1. t-bast (67)
  2. niftynei (64)
  3. roasbeef (41)
  4. cdecker (29)
  5. BlueMatt (28)
  6. rusty (21)
  7. ariard (20)
  8. lightningbot (3)
  9. sstone (1)


Generated by MeetBot 0.1.4.