#lightning-dev Meeting

Meeting started by cdecker at 20:08:30 UTC (full logs).

Meeting summary

    1. https://github.com/lightningnetwork/lightning-rfc/issues/774 (cdecker, 20:08:38)

  1. Adding a responsible disclosure document for the spec and pointers to the various implementations (#772) (cdecker, 20:09:37)
    1. https://github.com/lightningnetwork/lightning-rfc/issues/772 (cdecker, 20:09:48)
    2. ACTION: Add "faultive" to the merriam-webster dictionary (cdecker, 20:10:32)
    3. AGREED: everyone to discuss the details on the pull request (cdecker, 20:16:22)

  2. Channel announcement features (#769, #770, #773) (cdecker, 20:16:46)
    1. ACTION: cdecker to merge #773, and close #770 (cdecker, 20:19:51)

  3. Clarify Bolt 7 intro #760 (cdecker, 20:22:53)
    1. ACTION: cdecker to apply #760 (cdecker, 20:27:20)
    2. ACTION: Rusty to test #758 (rusty, 20:28:34)
    3. ACTION: all implementations to verify the new test vectors in #758 (cdecker, 20:29:48)

  4. Bolt 11 test cases #736 (cdecker, 20:31:17)
    1. ACTION: rusty to rebase and merge #736 (cdecker, 20:34:01)

  5. Network pruning #767 (cdecker, 20:35:41)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/767 (cdecker, 20:35:58)
    2. ACTION: everyone to discuss the pros and cons of using one update over the other on the PR (cdecker, 20:53:37)

  6. Protocol testing framwork (cdecker, 20:55:37)
  7. Anchor outputs #688 (@joostjager) (cdecker, 21:08:51)


Meeting ended at 21:21:59 UTC (full logs).

Action items

  1. Add "faultive" to the merriam-webster dictionary
  2. cdecker to merge #773, and close #770
  3. cdecker to apply #760
  4. Rusty to test #758
  5. all implementations to verify the new test vectors in #758
  6. rusty to rebase and merge #736
  7. everyone to discuss the pros and cons of using one update over the other on the PR


Action items, by person

  1. cdecker
    1. cdecker to merge #773, and close #770
    2. cdecker to apply #760
  2. rusty
    1. Rusty to test #758
    2. rusty to rebase and merge #736
  3. UNASSIGNED
    1. Add "faultive" to the merriam-webster dictionary
    2. all implementations to verify the new test vectors in #758
    3. everyone to discuss the pros and cons of using one update over the other on the PR


People present (lines said)

  1. cdecker (90)
  2. BlueMatt (70)
  3. roasbeef (49)
  4. rusty (46)
  5. bitconner (34)
  6. t-bast (33)
  7. joostjgr (16)
  8. niftynei (14)
  9. lightningbot (2)
  10. jkczyz (1)
  11. sstone (1)


Generated by MeetBot 0.1.4.