#lightning-dev Meeting

Meeting started by t-bast at 20:08:37 UTC (full logs).

Meeting summary

  1. The everlasting anchor outputs debate (t-bast, 20:09:05)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/688 (t-bast, 20:09:20)
    2. ACTION: ariard to summarize the security loss the two-anchors create, so that we evaluate it next time (t-bast, 20:35:10)

  2. Static remotekey test vectors (t-bast, 20:42:17)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/758 (t-bast, 20:42:23)
    2. ACTION: t-bast to try to gather people for a voice call before next time to discuss these anchor issues more efficiently (t-bast, 20:43:14)
    3. ACTION: c-lightning to validate the test vectors (t-bast, 21:10:25)
    4. ACTION: finalize comments on the PR and merge once verified by enough implementation (t-bast, 21:12:43)

  3. cltv_expiry_delta recommendations (t-bast, 21:13:21)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/785 (t-bast, 21:13:24)
    2. ACTION: t-bast recommend even higher value (yay!) (t-bast, 21:20:19)
    3. ACTION: t-bast explain why a dynamic value makes sense (t-bast, 21:20:41)
    4. ACTION: t-bast properly name the "deadline" and recommend a higher value than 7 (t-bast, 21:21:15)


Meeting ended at 21:30:58 UTC (full logs).

Action items

  1. ariard to summarize the security loss the two-anchors create, so that we evaluate it next time
  2. t-bast to try to gather people for a voice call before next time to discuss these anchor issues more efficiently
  3. c-lightning to validate the test vectors
  4. finalize comments on the PR and merge once verified by enough implementation
  5. t-bast recommend even higher value (yay!)
  6. t-bast explain why a dynamic value makes sense
  7. t-bast properly name the "deadline" and recommend a higher value than 7


Action items, by person

  1. ariard
    1. ariard to summarize the security loss the two-anchors create, so that we evaluate it next time
  2. t-bast
    1. t-bast to try to gather people for a voice call before next time to discuss these anchor issues more efficiently
    2. t-bast recommend even higher value (yay!)
    3. t-bast explain why a dynamic value makes sense
    4. t-bast properly name the "deadline" and recommend a higher value than 7
  3. UNASSIGNED
    1. c-lightning to validate the test vectors
    2. finalize comments on the PR and merge once verified by enough implementation


People present (lines said)

  1. t-bast (93)
  2. roasbeef (69)
  3. ariard (52)
  4. rusty (41)
  5. BlueMatt (25)
  6. joostjgr (25)
  7. bitconner (12)
  8. harding (3)
  9. renepick1 (2)
  10. lightningbot (2)
  11. cdecker (1)


Generated by MeetBot 0.1.4.