#lightning-dev Meeting

Meeting started by cdecker at 19:07:20 UTC (full logs).

Meeting summary

    1. https://wiki.debian.org/MeetBot if anyone is curious (rusty, 19:07:59)
    2. https://github.com/lightningnetwork/lightning-rfc/issues/805 (cdecker, 19:08:49)

  1. Clarify bolt 4 #801 (cdecker, 19:11:15)
  2. BOLT 4: link to BOLT 1 for tlv_payload format #801 (cdecker, 19:11:29)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/801 (cdecker, 19:11:37)
    2. ACTION: rusty to try out the change and report success/failure (cdecker, 19:20:06)

  3. Require to claim revoked local output in its own penalty tx post-anchor #803 (cdecker, 19:20:31)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/803 (cdecker, 19:20:36)
    2. AGREED: looks good, needs addressing the nits (cdecker, 19:31:19)

  4. Fail channel in case of high-S remote signature reception #807 (cdecker, 19:32:10)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/807 (cdecker, 19:32:10)
    2. AGREED: cdecker to merge the PR and defer grouping the prescriptions to a later point in time (cdecker, 19:41:45)

  5. Prevent preimage reveal collision while claiming onchain incoming HTLC #808 (cdecker, 19:42:06)
    1. https://github.com/lightningnetwork/lightning-rfc/pull/808 (cdecker, 19:42:06)
    2. AGREED: everyone to help make the formulation a bit more explicit (cdecker, 20:03:30)

  6. Make invoice's `s` flag mandatory ? #809 (cdecker, 20:04:15)
    1. https://github.com/lightningnetwork/lightning-rfc/issues/809 (cdecker, 20:04:16)
    2. https://github.com/lightningnetwork/lightning-rfc/pull/772 (realCdecker, 20:08:28)
    3. AGREED: Documenting the reporting process was accepted. The document needs to add contact details (e-mail and gpg keys) for the implementations and add details about what _not_ to do (report CVEs via the Twitter tag #StealMyMoney) (cdecker, 20:21:23)


Meeting ended at 20:25:07 UTC (full logs).

Action items

  1. rusty to try out the change and report success/failure


Action items, by person

  1. rusty
    1. rusty to try out the change and report success/failure


People present (lines said)

  1. cdecker (80)
  2. roasbeef (75)
  3. bitconner (39)
  4. rusty (34)
  5. realCdecker (23)
  6. t-bast (21)
  7. t-bast-official (18)
  8. ariard (15)
  9. realBitconner (11)
  10. lndbot (6)
  11. lightningbot (3)
  12. niftynei (2)


Generated by MeetBot 0.1.4.